[ 8 posts ] 
 Errors in forum? 
Author Message

Joined: 26 Mar 2010, 04:39
Posts: 109
Post Errors in forum?
At the moment I am getting errors when I try to submit any Latex code. Is anyone else experiencing this? This occurs even for very simple formulas in which there are definitely no erros.

e.g. if I enter something like this:
p^2
within the tex delimiters, I get an error like this:
Code:
[phpBB Debug] PHP Notice: in file /home/sdculver/public_html/roadtoreality/latexrender/class.latexrender.php  on line 281: copy(79cbe1508eeae14889e54f445af212c9.gif) [function.copy]: failed to open stream: No such file or directory
[phpBB Debug] PHP Notice: in file /home/sdculver/public_html/roadtoreality/latexrender/class.latexrender.php on line 299: unlink(/79cbe1508eeae14889e54f445af212c9.aux) [function.unlink]: No such file or directory
[phpBB Debug] PHP Notice: in file /home/sdculver/public_html/roadtoreality/latexrender/class.latexrender.php on line 301: unlink(/79cbe1508eeae14889e54f445af212c9.dvi) [function.unlink]: No such file or directory
[phpBB Debug] PHP Notice: in file /home/sdculver/public_html/roadtoreality/latexrender/class.latexrender.php on line 302: unlink(/79cbe1508eeae14889e54f445af212c9.ps) [function.unlink]: No such file or directory
[phpBB Debug] PHP Notice: in file /home/sdculver/public_html/roadtoreality/latexrender/class.latexrender.php on line 303: unlink(/79cbe1508eeae14889e54f445af212c9.gif) [function.unlink]: No such file or directory
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3824: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3247)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3826: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3247)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3827: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3247)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3828: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3247)


29 May 2010, 02:00
Supporter
Supporter

Joined: 07 Jun 2008, 08:21
Posts: 235
Post Re: Errors in forum?
Hi Robin
Yes, several of us are having these problems and they have been reported to Shaun Culver the forum administrator. So we are just waiting for him to sort things out.
If nothing happens I will try and contact Shaun by other means outside the forum and get something done.
It's very frustrating I know.
Vasco


29 May 2010, 05:42
Supporter
Supporter

Joined: 07 Jun 2008, 08:21
Posts: 235
Post Re: Errors in forum?
If anyone is on Facebook or twitter or a member of linkedln then they could contact him directly about this problem. To make sure you get 'our' Shaun Culver, here is a link with some details. He lives in CapeTown South Africa:
http://za.linkedin.com/in/shaunculver
Please let us know if anyone manages to contact him.
Vasco


29 May 2010, 06:09
Site Admin
User avatar

Joined: 25 Feb 2008, 13:32
Posts: 106
Location: Cape Town, South Africa
Post Re: Errors in forum?
Hi everyone,

I've been in contact with the web host, and so far we haven't fixed this issue yet. Their latest response:
Quote:
Honestly, I don't know what else to try, we updated latex and all its dependences, mirrored the current PHP and APache configuration on the old server, files are exactly the same too. I'm out of ideas, 3 of us were working here and none of us know what else to try, if you have a new approach we can try it.

I don't have much time to spend on this at the moment, I apologize, but if anybody has suggestions, I'd be glad to forward it to the web host.

_________________
Our imagination is stretched to the utmost, not, as in fiction, to imagine things which are not really there, but just to comprehend those things which are there.


08 Jun 2010, 19:12
Site Admin
User avatar

Joined: 25 Feb 2008, 13:32
Posts: 106
Location: Cape Town, South Africa
Post Re: Errors in forum?
Another thing, if this issue persists, I'll move the forum to a new web host.

_________________
Our imagination is stretched to the utmost, not, as in fiction, to imagine things which are not really there, but just to comprehend those things which are there.


08 Jun 2010, 20:59

Joined: 08 Jul 2010, 20:17
Posts: 2
Post Re: Errors in forum?
just out of interest, if you quote latex formulae that do render (ie old posts) and preview them, they still render. it's just new posts that seem to have problems


09 Jul 2010, 21:04

Joined: 12 Jul 2010, 07:44
Posts: 154
 Re: Errors in forum?
If you've mirrored all the files on another server, and that one's working, then I'd guess it might possibly be a directory permissions issue. Look at the error messages - it's trying to copy (newly-generated GIF) files, and they simply aren't there.

This could be because the latex compiler isn't working... but if an identical copy of it works, that's probably not the reason; and there were no latex compilation errors displayed.

So what I think might be happening is that the latex compiler working fine, but when it finishes and tries to save its output, it's failing (silently) because the permissions on the destination directory won't let it save there (or else perhaps that directory has been deleted or renamed).

Then subsequent code is looking for the latex output file, in order to insert it into the website, and it can't find it; hence the error messages (it's also trying to delete unneeded output files as well - that's what the 'unlink' errors are from).

You should have your web hosts check:

(a) That the output directory for the latex compiler exists.

(b) That directory permissions are set to allow the latex compiler to save files there.

(c) If it's possible to invoke the latex compiler directly, check that this works, and does indeed save files in the correct directory.

(d) Verify that the BBS php code is looking for the latex output files in the same directory that the compiler is (supposed to be) saving them. (This might be a configuration option - in the latex compiler, in the BBS software, or in both?)


NOTE: If this is all obvious and belongs in the 'That's the first thing we tried' category, then I apologize for the condescension!


Good Luck,

-- Dean


13 Aug 2010, 19:02
Site Admin
User avatar

Joined: 25 Feb 2008, 13:32
Posts: 106
Location: Cape Town, South Africa
Post Re: Errors in forum?
Hey everyone,

I've moved the forum to a new server, and have got LaTeX working again:

4 - 3 = 1

I apologize for any convenience this may have caused.

_________________
Our imagination is stretched to the utmost, not, as in fiction, to imagine things which are not really there, but just to comprehend those things which are there.


10 Jan 2012, 11:44
   [ 8 posts ]